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The Joomla E-Commerce extension VirtueMart has been installed worldwide about 250,000 times.

With version 2 of  the VirtueMart extension the software reached a new level of  quality.

This book provides an introduction to VirtueMart.
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1. What is VirtueMart?

http://www.flickr.com/photos/hagengraf/8498030903/

E-commerce is an important, but unfortunately confusing topic.

Anyone toying with the idea to sell something online, must learn about topics  such as  payment 
gateways,  shipping interfaces, the integration of the shopping extension into an existing website and of 
course,  need to get familiar with the existing laws concerning e-commerce in the country/countries 
targeted.

Online shops are in many cases operated separately from the existing website which is often driven 
by a content management systems (CMS).
The large open-source systems (Joomla,  Drupal, WordPress) offer enhancements  that allow you to 
integrate the online shop in the CMS (website). The integration has the advantage that other existing 
CMS extensions can be used, for example, the management of  news.
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In this article I would like to introduce VirtueMart, the e-commerce extension for the CMS Joomla.

E-COMMERCE WITH VIRTUEMART
When it comes  to the integration of e-commerce in Joomla, VirtueMart is the most common 

extension (http://virtuemart.net/). The extension exists since many years  and was  originally a separate 
project (PHP shop),  which was adapted from the German developer Sören Biermann to the Joomla 
predecessor system, Mambo. Over the years,  VirtueMart was developed more closely to the Mambo / 
Joomla system. Today it is well integrated into Joomla and it uses in many places the Joomla Platform.

Worldwide, there is a big fandom, that operates their online businesses with Virtuemart.

Opinions are divided on VirtueMart. Some believe it is simple and useful, for others it's an 
inoperable monster.

After the release of Joomla 2.5 the Virtuemart team has released version VirtueMart 2, which is a 
completely new development. Users of the old version 1.x (which is based on Joomla 1.5)  are forced to 
update, because the status of  Joomla 1.5 is "End of  Life (EOL)" since fall 2012.

So the question is not whether you're upgrading to VirtueMart 2, but when you're upgrading.

INTERVIEW WITH PROJECT LEAD MAX MILBERS
Max Milbers is  VirtueMart project lead and answered a few questions about VirtueMart on 

February 28, 2013.

http://www.flickr.com/photos/osiberia/5346949748/

How many online stores worldwide use VirtueMart ?
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There are different numbers depending on whether you check Vertical Pigeon ( verticalpigeon.com ), 
Alexa (alexa.com)  or BuildWith (builtwith.com). But about 250,000 users (shops)  have emerged. Of 
these, around 70,000 already with VirtueMart 2.

What are the reasons why so many people use VirtueMart?

VirtueMart is free. We mean not only that it is available for free download ,  but also the design 
patterns we use are known and quickly readable for experienced programmers  . It contains  no 
restrictions, such as maximum number of products  or a limited category depth. Another very important 
reason for our users  is the VirtueMart community,  which provides countless free code snippets . A large 
number of free extensions makes VirtueMart 2 one of the most flexible shop solutions in general. 
Because of the modular architecture VirtueMart 2 is very slim and requires only few resources ,  no large 
server is needed and therefore VirtueMart suitable for almost everyone.

What are the main differences between VirtueMart version 1.x and 2.x ?

The main difference for most Web developers  will be the revised templating. VirtueMart 2 uses 
completely the template system of Joomla . Many adaptations can be made directly with the template 
override system of Joomla . Due to the extended plugin system , which is  also based completely on 
Joomla plugins , the core can be adjusted easily without "hacking" it .
For each shop owner perhaps the biggest change is  the rule-based price modification system that provide 
s abstract rules to calculate taxes  ,  discounts, rebates and suchlike . Also for different types of product 
variants  ,  a new system was developed,  which is more flexible and appropriate plugins  leave nothing to 
be desired ( yard goods, product configurator , ... ) .

Is there an upgrade path from Joomla 1.5 / VirtueMart 1 to Joomla 2.5/ VirtueMart 2 
for a standard VirtueMart 1 store ?

There are different ways,  that depends  a bit on the other components  used. VirtueMart 2 runs on 
Joomla 1.5 ( new features are not tested anymore)  and on Joomla 2.5. My preferred way is  to update 
Joomla 1.5 to Joomla 2.5,  then rename the com_virtuemart folder and install  VirtueMart 2 easy on top 
of the VirtueMart 1 installation . Than you can run the native migrator. No files are deleted and if 
required, the old state can be restored relative quickly. We provide a detailed tutorial .

Are there any countries where VirtueMart is used most often ?

To our knowledge, these are the USA with 25 % of users, Russia, and some Asian countries. They 
often have their own communities. The German-speaking countries are catching up .

A big issue in in e-commerce is "legal compliance". In which countries you can run a 
VirtueMart shop "legally"?

VirtueMart "out of the box" is probably nowhere "legal" but everywhere with a few adjustments. It 
also depends on which lawyers you have to advise one ;)
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What are the biggest challenges in developing an e-commerce extension ?

Most VirtueMart users use only 20% of the package and often know only 30% of the options and of 
course everyone else uses other 20% than the rest. So   often you have to develop and share a common 
vision between different, but very similar user ideas.

We want to present in the next few articles VirtueMart and explain its operation. What 
topics do you think are the most important ones ?

The calculation rules, the self-generated fields, the template overwrite system, the language system. 
The most important thing in the end, the basics. Which session do I need in Joomla ? Can I use the 
cache? etc.

How many developers are currently working on the VirtueMart project ?

Very difficult to say. Officially,  we have two main developers (Valérie Isaksen and me)  and about five 
people that regularly send patches  and implement a whole feature. There are also about 30 developers 
who were only working on a particular feature and now they left the project. In addition, we have been 
received and integrated improvements  and fixes  from about 100 forum users. Additional to that, about 
100 translators and more than 60 companies,  or freelancers provide free and commercial extensions. It 
can be said that around 200 people have been involved. If you want to count the users who helped each 
other i n the forums , than we are talking a bout 10,000 contributers.

So to answer the question conclusively , let's say five people are working constantly on the project .

Are there VirtueMart events?

Currently not. We are taking part and support the national Joomla Days. A larger event centered on 
VirtueMart is planned.

There was a seminar in Madrid for Web developers to obtain a certificate. This was  a great success, 
we are planning at least two more of  such seminars for 2013.

How can you help the VirtueMart team ?

A very big help to us  is to participate in the forum and help other users to discuss  errors  and maybe 
directly provide a fix.

Are there other comparable Joomla , Drupal, WordPress extensions used at similar 
rates ?

According to the official figures, no. However, I'm very busy with VirtueMart, so there is  no time to 
investigate such things seriously.

How do you see the future of  VirtueMart ?
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Currently I am very optimistic. Since version 2.0.14 the code has  hardly serious  bugs ,  since version 
2.0.18a the code has become more robust and faster. I already have seen a VirtueMart 2 market place 
with 820,000 products, which runs on a normal VServer with acceptable speed.
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2. Installation and Basic Settings

http://www.flickr.com/photos/hagengraf/871585986

To use VirtueMart you need to install it first and you also need an existing Joomla installation. In our 
examples  we are working with VirtueMart 2.x and Joomla 2.5. If you are not familiar with the Joomla 
2.5 Installation,  please read the Joomla 2.5 Installation chapter. Joomla 2.5 is  the stable branch until 
summer 2014.

If you want to use VirtueMart in a single language (e.g. German)  it is useful to configure your Joomla 
installation BEFORE the VirtueMart installation to that language too (German).

It is possible to use VirtueMart in a multi language environment. Nevertheless  you should use the 
language VirtueMart was initially installed as "main" language. 

DOWNLOAD AND EXTRACTION
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Go to virtuemart.net and download the 2.x package (http://virtuemart.net/downloads). A file with 
the name com_virtuemart.2.0.18a_extract_first.targz.zip will be downloaded to your hard disk.

After extracting the package you find three files

README-VIRTUEMART.txt

com_virtuemart.2.0.18a.tar.gz

com_virtuemart.2.0.18a_ext_aio.tar.gz

The text files  contains a link to the VirtueMart2 Install Instructions (http://dev.virtuemart.net/
projects/virtuemart/wiki/Easy_VirtueMart_2_Install_Instructions).

INSTALLATION CORE
Primary you have to install the VirtueMart 2 Core (com_virtuemart.2.0.18a.tar.gz). Log in as  the "super 

administrator" in the administration area of Joomla and go to Extensions → Extensions Manager → Install. 
After uploading the extension you will see this screen (Figure 1).

Figure 1: Installation of  VirtueMart 2 Core

At a first look it is a bit confusing, but everything is ok. VirtueMart 2 is  successfully installed and you 
have to decide whether you want to install the sample data or not. But before we do that let's have a look 
at the messages on top of  the screen. The first group are information messages.

• Info: created table b4mjy_virtuemart_products_en_gb

• Info: created table b4mjy_virtuemart_vendors_en_gb
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• Info: created table b4mjy_virtuemart_categories_en_gb

• Info: created table b4mjy_virtuemart_manufacturers_en_gb

• Info: created table b4mjy_virtuemart_manufacturercategories_en_gb

• Info: created table b4mjy_virtuemart_paymentmethods_en_gb

• Info: created table b4mjy_virtuemart_shipmentmethods_en_gb

• Info: Taking config from file

They tell us that a few tables were created in the database. The name of the tables start with b4mjy 
which is  the database prefix of my Joomla installation. These tables are the language specific tables. If 
you are able to have a look into your database (e.g. via phpMyAdmin)  you can see these tables and many 
more that are created by VirtueMart.

The next message is a warning

Warning, the Safe Path is empty, for safety reasons it is very  important to create a folder in a path  not accessible by an 
URL, create also a folder invoices in it to store your sensitive data secure. Our suggested path  is for your system /Users/
hagengraf/Documents/htdocs/vmfiles, use this ...

VirtueMart needs  a path to a folder that is  not inside the public webserver directory to store sensitive 
Data. In my case,  the Joomla document root is /Users/hagengraf/Documents/htdocs/vm2. The system makes 
a proposal for an appropriate name and path (/Users/hagengraf/Documents/htdocs/vmfiles).

If you are new to VirtueMart it is  a good idea to install the sample data to get an idea what's possible 
with this extension. Click the Icon Install Sample Data and your sample data will be installed.

If  something went wrong ...

Sometimes,  you spend time reading this article or got a fresh coffee. When I clicked the Install 
Sample Data button my Joomla session was  expired and Joomla showed me the login dialog. After 
logging in I didn't see the install page anymore, so my shop was  without sample data. Don't panic if that 
happens to you. VirtueMart comes  with several tools  like the "Reset all tables  and install sample data" 
tool. Just go to Components → VirtueMart → Tools (Figure 2).

E-Commerce with VirtueMart 2

Sunday, 28 July 2013 Page 12



Figure 2: VirtueMart Tools

On top of the screen you see a message "To use these tools  fully, you must check 'Enable database 
Update tools' in the Configuration panel." (Configuration panel is  linked). Any time you want to use 
these tools, you have to click the configuration panel link and check "Enable database Update tools". 
Then go back to tools and click the "Reset all tables and install sample data" Icon.

The Safe Path
As already mentioned we have to configure the safe path (Figure 3).
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Figure 3: Safe Path

As long as you haven't done it you'll see a message on top of the administrations  pages  with a 
proposal for the name and a link where to add the folder. Create the folder,  copy the proposed path to 
Extensions → VirtueMart → Configuration → Templates → Media File Settings and save it. VirtueMart will 
create a folder called "invoices" inside the Safe Path.

INSTALLATION "ALL IN ONE"
After the core we have to install the other necessary bits and pieces  like e.g. payment methods. 

Therefore,  the VirtueMart team provided an AIO (All in one)  package as  an add on to the VirtueMart 
core. Install the com_virtuemart.2.0.18a_ext_aio.tar.gz package via Extensions → Extension Manager → Install. 
The AIO package adds Modules and Plugins to your Joomla/VirtueMart installation.

Modules
• VirtueMart Category

Shows the categories of  the shop

• VirtueMart Manufacturers
Shows a list of  Manufacturers

• VirtueMart Products
A list of  featured products
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• VirtueMart Search Product
A search module for products

• VirtueMart Shopping Cart
Displays the content of  the shopping car as a module

• Virtuemart Currency Selector 
Shows the currencies  of the shop. If another currency is  chosen,  the price will be calculated 
automatically

Plugins
Type vmcalculation

This  type contains plugins, that help calculating the price. VirtueMart2 comes with the Avalara 
plugin, an on demand tax calculation for whole U.S.A (http://www.avalara.com/)

Type vmcustom
• Product Specification - This plugin is  deprecated and only for compatibility reasons in the 

VirtueMart2 package

• Stockable Variants  - Assign a name and the values for the options of a child product with stock 
control

• Customer Text Input - allows customers to specify their own value, like for asking for the name to 
engrave a product.

Type vmpayment
This plugin type contains 15 payment methods!

• Authorize.net

• Standard

• PayZen

• Paypal

• Moneybookers Skrill Digital Wallet

• Moneybookers Sofortueberweisung

• Moneybookers Przelewy24

• Moneybookers Online Bank Transfer

• Moneybookers iDeal

• Moneybookers Giropay
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• Moneybookers Lastschrift

• Moneybookers Credit Cards

• Klarna

• Heidelpay

• SystemPay

Type vmshipment
This  type contains plugins  for shipment of products. VirtueMart2 comes with the "By weight, ZIP and 

countries" plugin.

DISPLAY THE SHOP IN THE JOOMLA FRONTEND
So far, we successfully built an online shop using Joomla and VirtueMart with predefined sample 

data.
To see it in the Joomla Frontend we have to add a menu link. In VirtueMart 2 there are several menu 
item types available.

Go to Menus → Main Menu → Add New Menu Item and choose the menu item type VirtueMart 
frontpage (Figure 4).

Figure 4: VirtueMart Menu Item Types
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With the new menu link we can access the shop on our Joomla website. The modules  in the left 
sidebar are activated by default after installing the "All in One" package (Figure 5).

Figure 5: VirtueMart 2 and Joomla 2.5

You can now "walk through" your shop to get a feeling what is this all about.
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3. Selling Products in Your Shop

http://www.flickr.com/photos/hagengraf/7614590126

n the last chapter we managed the installation of VirtueMart 2 and we explored the example data. In 
this  chapter I want to remove the example data from the shop and add my own products. I live in a small 
village in France which is called Fitou and it's known worldwide for it's red wine. So I decided to create a 
wine store. 

CREATING THE SHOP "VIN DE FITOU"
As always,  there are several things to keep in mind when you start your business. I just want to cover 

the technical part  :-)

VirtueMart 2 Update
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I noticed that in the meantime a new version of VirtueMart was released and I had to update the 
software via the so called Live Update. It is  important to run the newest version of Joomla and 
VirtueMart to avoid security holes. When you sell your products on line and store the contact data of 
your clients it's even more important to think about secure software.

Luckily,  this  process  it very easy. You just have to click the update icon (Figure 1). Like the installation 
process,  the update process  is  separated too in a "core" and an "all in one" update. Don't forget to update 
the "all in one" package! Therefore, visit Components → virtuemart aio in the Joomla backend and click the 
update button (Figure 2).

Figure 1: VirtueMart 2 core update

E-Commerce with VirtueMart 2

Sunday, 28 July 2013 Page 19



Figure 2: VirtueMart 2 aio update3

Delete the example data
We still have the example data in our shop and I want to remove them. The most secure way to 

delete all data is to use the "Reset all tables and do a fresh install" tool in Components → VirtueMart → Tools & 
Migration.

Shop description
Our clients  need to know where the shop is  located and which currency is  accepted. In Components → 

VirtueMart → Shop  → Shop   you have to fill out the form (Figure 3). Data needs to be inserted in both tabs. 
It is necessary to define a currency, the name of  the shop, a description, the postal address, etc
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Figure 3: Shop data

Payment method
You need to define a payment method. The VirtueMart All in One package already installed a few. 

Go to Components → VirtueMart → Shop  → Payment methods and click the new icon. I configure the PayPal 
service as an example (Figure 4).
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Figure 4: Payment Method PayPal

Before you can add your PayPal email address you have to save the payment method and edit it 
again (or save and switch the tab). When you test your shop for the first time,  use PayPals  sandbox (Figure 
5). The sandbox mode is offered by PayPal for testing purposes. When you buy a product you will be 
redirected to the PayPal sandbox system that simulate the payment process. You can check with your 
own PayPal user account whether everything works as expected. When the shop goes  live you have to 
switch the sandbox mode off. Don't forget to publish the payment method!
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Figure 5: Payment Method PayPal configuration

Shipping & Taxes
For the very first beginning we'll send our wine without shipping costs and don't care about taxes ;-)

Product Category
So far we just sell red wine, but later on we will also sell other sorts of wine,  therefore I need to create 

categories. Go to Components → VirtueMart → Products → Product Categories and create a category called 
"Red". You can use this photo (http://www.flickr.com/photos/hagengraf/7...)
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Figure 6: Product Category

Manufacturer
The last bit we need is  the manufacturer of the product. In our case it's  the local wine maker 

"Domaine La Garrigot". Go to Components → VirtueMart → Manufacturers → Manufacturers and add a 
manufacturer for your first product (Figure 7). It's possible to describe the manufacturer as detailed as you 
wish, including image, URL and email.

Figure 7: Manufacturer

THE FIRST PRODUCT
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As you may assume our first product is  a bottle of wine. I've taken two photos (bottle frontside, bottle 
backside)  and will keep the product creation process as simple as possible. Go to Components → VirtueMart 
→ Products → Products → New and fill the form fields of  the six tabs.

Product information
In this  tab you can insert the SKU (Stock Keeping Unit), the product name, the product alias,  the 

manufacturer, the category and the cost price (Figure 8). SKU and manufacturer are not mandatory but 
in our case useful. The cost price is  the basic price of your product, on top of this  you can set up rules to 
create different prices. We will come back to this point later on.

Figure 8: Product information

Product Description
In this tab you can insert a short and a long description and the metadata of  the product (Figure 9).
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Figure 9: Product description

Product Status
In this tab you can manage your stock and send emails  to customers and connect. The VirtueMart 

Team recommends to use the AcyMailing component because of  performance reasons .

Product Dimensions and Weight
For shipping calculation insert the dimensions and the weight.

Product Images
Upload as  many images as  you want for your product (Figure 10). If you have more than one image 

you can choose the image you want to edit by clicking the icon on the bottom right of the image 
thumbnails.
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Figure 10: Product images

Custom Fields
For our example we don't need custom fields. They are important e.g. for downloadable products. 

We'll cover that topic in a separate chapter.

DISPLAYING THE PRODUCT IN THE FRONTEND
To display the product in the frontend we can use the existing shop link in the main menu or create a 

new menu item with a direct link to our new product (Figure 11).
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Figure 11: New product on our website

Now you have configured a complete online shop in VirtueMart. The shop itself is still simple but it 
works.

• Play around with the options in the backend and the display of  the product

• Try to buy your product!
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4. Buying Process and Order 

Management

http://www.flickr.com/photos/yourdon/3475417696

In the last chapter we set up a product in VirtueMart and in the meantime I learned about cultural 
differences in online shopping compared to traditional shops. The reason is  quite simple. The 
VirtueMart articles  are translated to various languages and one of them is Arabic. As you already know 
Fitou, the village I live in, is known for its red wine but in some countries  alcohol is a sensitive topic. So I 
decided to switch to another product in the Arabic version of the book. The same can happen to your 
products  in your online shop. It can be seen all around the world. On the one hand that's  very good 
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because everyone in the world is  able to buy something. On the other hand you have to be aware of 
different cultural habits.

By the way,  when you start selling products or services online,  you need to verify if your product /
service is suitable for being sold online.

Check

• if  you need an online help to use your product

• your transportation abilities  & costs,  compare your total inventory holding costs  to the cost savings 
when using the a method of  transport

• if  it would be necessary to offer technical support or after sales service?

• if  your product adapts to different environments (cultures, climates)?

Today we want to have a look at the buying process and the order management. So far, we have a 
product, the PayPal payment method, no shipping options and no taxes.

Shopping cart
Most online shop systems are using a shopping cart or a kind of basket like in a super market. 

Visitors can explore the site and are able to put goods in their shopping cart. They just have to click the 
"Add to cart" button (Figure 1) .

Figure 1: Add something to your shopping cart 

The default behavior in VirtueMart is:
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1. Click add to cart

2. A popup window appears with a message

3. The shopping cart module is automatically updated

4. You are still at the same product display page

On a desktop pc this  is just easy. If you are on a mobile device, the popup window can be disturbing. 
In Components → VirtueMart → Configuration → Checkout you can uncheck Display modal popup upon 'Add 
to cart'  (Figure 2) and the behaviour changes to

1. Click add to cart

2. You will be redirected to your shopping cart page

Figure 2: Checkout configuration

Visitors can continue shopping and they can update their shopping cart. The cart information is 
stored in the local browser and there is no need for the visitor to register. 

Checkout process
Once a visitor wants  to checkout it is important that the shopping cart is  easy to find. There are two 

possibilities to display the cart. Via the shopping cart module or via a menu item link in the menu. The 
shopping cart module displays the content of the cart but depending on the position at the site it can be 
hard to find. A link in the main menu displays no information about the content of the cart but it's easy 
to find. You can use both possibilties to make it easy to checkout. 
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The default shopping cart display looks like the one in Figure 3. The checkout button is at the right 
bottom.

Figure 3: Default shopping car

You have to think about the way you want to interact with your customers and how you want to 
configure the display of  your shopping cart. Just a few examples:

Should people register to your site before checkout or do you allow them to checkout as a guest.

If  you want a registration, there should be a possibility to register on checkout
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Do people have to agree to the terms of  service once or at every order

You find all the configuration settings in Components → VirtueMart → Configuration → Checkout.

If necessary, VirtueMart collects  two addresses, the billing and the shipping address. It starts  with the 
billing address. Our client Toni enters his billing address and decides to register (Figure 4). 
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Figure 4: Billing Address and automatic registration

Toni is immediately logged in and the underlying Joomla user registration system shows a message.
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Your account has been created and an activation link has been sent to the e-mail address you 
entered. Note that you must activate the account by clicking on the activation link when you get the e-
mail before you can login.

You can change the configuration of the Joomla registration process  in Users → User Manager → 
Options → New User Account Activation.

The vendor (shop owner in our case) gets  an email too that someone registered in the shop (Figure 5) 
and our new customer Toni is listed as a shopper in Components → VirtueMart → Orders & Shoppers → 
Shoppers (Figure 6).

Figure 5: Notification vendor email

Figure 6: VirtueMart shoppers
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To finally buy the products,  our new customer Toni has  to click the "Confirm Purchase" button. 
VirtueMart will redirect him to the selected payment system. We configured PayPal, so Toni is  send to 
the PayPal System (Figure 7).

Figure 7: PayPal Payment

In PayPal for VirtueMart 2 the vendor and customer will only receive an email when the transaction 
is complete. Here is an example for a confirmation email (Figure 8).
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Figure 8: Order confirmation email

Now the product is ordered and paid.

Order management
Both, the customer and the vendor received notification emails

Customer:

• Email from the Joomla core system (depending on configuration)

• Email order notification

Vendor:

• Email that someone registered in the shop

• Email order notification

The customer is  now able to login with his  username and password. VirtueMart 2 offers a menu 
item type for customers called Account Maintenance. Setup a user menu that is  only visible by registered 
users and add the account maintenance link. Toni can now see his order and the order history (Figure 9).
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Figure 9: Order history in frontend

The vendor can see the order in Components → VirtueMart → Orders & Shoppers → Orders (Figure 10) 
and can create an invoice by clicking the invoice icon. The generated PDF is stored in the safepath folder 
(Figure 11)  and it is  not accessible to the public via browser. The detailed order can be accessed by 
clicking the order number.

Figure 10: Order list in backend
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Figure 11: vmfiles folder with invoice

Even if this  is  a very easy example the vendor has to ship the goods to the customer. The orders  have 
different statuses and so far Tonis order is confirmed which means that Toni paid for it and PayPal 
confirmed the payment. After the vendor sent the good, he has to update the order status. The update is 
possible in the order list view or in the detailed order view (Figure 12). Toni gets  an email and his order 
history is updated too (Figure 13).

Figure 12: Order update
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Figure 13: Order history

Conclusion
This  was  the general way in VirtueMart 2 about how to buy and how to manage an order. As  you 

already noticed during the process,  there are several little configuration options that can make your shop 
work better and more effective. Take the time and try out how it feels  to be a customer in your shop and 
explore the possible configuration options.
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5. Shipment and Taxes

http://www.flickr.com/photos/meesterdickey/6065515067

In this chapter I want to add shipping methods and taxes to our products.

Both topics  are in general "easy to setup" but at the same time more than complicate because of the 
different regulations in countries around the world.

SHIPMENT
VirtueMart 2 comes  with an inbuilt shipment plugin called "Shipment based on the Weight,  ZIP and 

Countries" that is highly configurable.
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In this chapter I'll use that plugin for a flatrate example with two options.

Creating the shipment methods

I create two shipment methods with the name "Shipment in 24 hours" and "Shipment in 2-5 
days" (Figure 1).

Figure 1: Shipment methods

In the configuration tab of each method I enter the shipment cost. This  shipment cost will be 
automatically applied to all orders (Figure 2).

Figure 2: Shipment costs

E-Commerce with VirtueMart 2

Sunday, 28 July 2013 Page 42



If you want to have different costs  for different weights you have to specify the lowest and highest 
weight and create as many shipment methods you need.

When Toni my "test client" is now buying something he has  to choose whether he wants to use the 
fast or the slow shipment method (Figure 3).

Figure 3: Select shipment method

VirtueMart shows the text "Discount/Fee" which is a bit misunderstandable. I don't like it and want 
to change it to "Fee". Joomla offers  a language string override system (Extensions → Language Manager → 
Overrides)  to change the values  of language string variables. You can search for "Discount/Fee" to find out 
t h e n a m e o f t h e l a n g u a g e s t r i n g v a r i a b l e . I n o u r c a s e i t ' s 
COM_VIRTUEMART_PLUGIN_COST_DISPLAY. Now it's possible to create an individual text 
(Figure 4).

Figure 4: Languages override

Afterwards the choice of  the shipment methods shows just the "Fee" text (Figure 5)
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Figure 5: Overriden text

Toni has to select a method and the amount of  money is added to his shopping cart.

VirtueMart offers several extensions. Have a look at third party shipment plugins for VirtueMart to 
find more solutions, e.g. the free plugin Shipping by Rules.

TAXES
Depending on the country, taxes are added to the product price in various ways.

Some countries  prefer to show the price without taxes on product pages. The necessary taxes are 
depending on the address of the customer and it's  only possible to show the correct amount in the 
checkout process.

Other countries it is  obligatory to show the price including taxes in the catalog. In this  case the 
amount of  tax is displayed on the product page and in the cart.

Shipment costs are subject of  tax too, of  course in various ways.

In some countries, taxes  are depending on the product type. E.g. in Germany the value added tax for 
a paperback book is lower than the tax for an ebook.

Another important criteria is whether your shop offers  goods from business-to-business (b2b) or from 
business  to customer (b2c). E.g. in Europe companies have a European value added tax identification 
number. If a company from Austria buys goods in Germany they don't have to pay German VAT. To 
verify the number the European Union offers  a web service. In the VirtueMart extension store a plugin is 
offered that validates the EU VAT Id during the checkout process, and assigns  a new group to the 
shopper (EU-VAT Checker).

After these first sentences I wasn't sure anymore what to show in this chapter :)

In general VirtueMart works with tax rules. To keep it simple it offers the possibility 
to create a "global" tax rule that affects any product price. Just create a new tax rule, 
enter the VAT percentage and you're done.

If you have more than one tax you can create more tax rules depending on various parameters. As 
an example I define a rule for France with a VAT of  19.6 % (Figure 6 and 7).
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Figure 6: Tax rules

Figure 7: Details for French tax rule

Tax overrides
In the product edit page it's  possible to override the rule based system (Figure 8). It should be only 

necessary if  you have a special case. In general it's possible to run a VirtueMart shop without overrides!
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Figure 8: Product pricing overrides

Product page
The price of  the product will be shown in the frontend product page like this:

Price:
Sales price: 11,95 €
Sales price without tax: 9,99 €
Tax amount: 1,96 €

VirtueMart itself calculates every price and tax from the base price of the product. The display of 
the different price types can be configured in VirtueMart → Configuration → Pricing (Figure 9).
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Figure 9: Prizing configration

As you see, there are endless possibilities  to create value added tax rules  based on shopper groups, 
countries,  products, currencies, states,  etc. You can find a more examples  in the VirtueMart 
Documentation section: Taxes and calculation Rules.
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6. Custom Fields and Product 

Variants

http://www.flickr.com/photos/12203106@N05/3548850949

The easiest case in your store is having a product that is  unique and has  no variants. But often you 
need to offer a product in different sizes,  colors  or other attribute so that your clients get exactly what 
they want. Sometimes,  these attributes have a relationship to the price and sometimes, they have 
different images and descriptions.

ABRICOT JAM 250GR OR 500GR?
Imagine you are selling home made apricot jam in two sizes,  250gr and 500gr. The 250gr pot is the 

standard size and costs  4 €. The 500gr pot costs  7 €. You don't want to use the inbuilt stock control 
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system in VirtueMart to manage your jam pot stocks. You just want to offer the different sizes for a 
different price. The product images and the descriptions are the same.

Create a custom field
To achieve your goal you have to create a custom field. Go to Components → VirtueMart → Products → 

Custom Fields and create a new field. Choose a name (e.g. pot),  as type Cart Variant and Yes for Cart 
Attribute (Figure 1).

Figure 1: Create Custom Field "Pot"

Add the field to your product
The custom field "Pot" is now available for any product in your store. You have to link the "Jam" 

product with the "Pot" field. Go to the edit page of your product and access the tab Custom Fields. Choose 
"Pot" as Custom Field Type for any sizes of  the pot you want to add (Figure 2).
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Figure 2: Link the Custom Field to the product

Choose a size!
Now it's possible to specify the size of  your jam jar on the product details page (Figure 3).
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Figure 3: Choose a product attribute

BLACK T-SHIRT FOR 12€ OR WHITE T-SHIRT FOR 10 €?
Imagine you are selling t-shirts. When a customer places  an order he might want to choose the color 

of the t-shirt. It would be nice for the customer to see the t-shirt in that color at the product page and it 
would be nice the shop owner can charge different prices for different colors. Let's  use the VirtueMart 
feature Child Products!

Creating the t-shirt products
For using child products  we need a parent product. A parent product can be any existing product. I'll 

create the white t-shirt product for 10 €   as usual in Components → VirtueMart → Products → Products → 
New. I upload the image with the white t-shirt and I enter the price of the white t-shirt. After saving the 
product I click the Add Child Product button on the bottom of the form to create the related child 
product "black t-shirt" (Figure 4).

Figure 4: Creation of  a child product

Now we have two separate products  that are linked to each other. The black t-shirt is the child 
product of  the white t-shirt (Figure 5).
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Figure 5: Product list with child product

Create a custom field
To display the choice between the t-shirt colours we need a custom field of the type Generic child 

variant. Give it a name (colour) and choose Yes in the Cart Attribute field (Figure 6)

Figure 6: Generic child variant field

Link the custom field to the parent product
Add the custom field colour to your parent product. In our case add it to the white t-shirt. When you 

check the Display parent as option field it is  not necessary to create a separate white t-shirt child product 
(Figure 7).
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Figure 7: Child products custom fields

Choose your desired colour!
When you now access the t-shirt product page you'll see two options and a text Choose a product 

variant first (Figure 8). The white t-shirt is listed too as  an option. When you choose the black t-shirt, the 
page reloads and a different image and price appears (Figure 9).
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Figure 8: White t-shirt
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Figure 9: Black t-shirt

MORE POSSIBILITIES WITH CUSTOM FIELDS
Custom fields are like a swiss army knife in VirtueMart 2. They are used for various tasks.

More structure with additional custom fields
Usually,  you have one big product description to each product but sometimes you want to have a 

certain structure to make it easier for visitors to read about the product and compare it with other 
products. If  you are selling washing machines you could need a structure like

• Part Number  (e.g. WTW4850XQ)

• Color (e.g. White)

• Standard Cycles  (e.g. 12)

• Access Location  (e.g. top loading)

Structured data are useful for nearly everything (smartphones, books, tv's, etc)
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VirtueMart offers  various  field types to structure your products (text). You can even choose the layout 
position in various ways, e.g. on top (ontop) or on bottom (onbot) of  the product images.

Just create the necessary fields and link them to your products.

Custom fields and plugins
Plugins make intensive use of custom fields  too. VirtueMart comes  with three custom plugins. One of 

it is  called Customer text input. If you offer e.g. the engraving of your products, customers  can insert the 
desired text (Product custom fields Plugin Customer Text Input). More plugins are available in the 
VirtueMart extension store, e.g. the Shipment for Virtual Products plugin.
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7. Templates

http://www.flickr.com/photos/hagengraf/8997161917

Your ecommerce website needs some style to attract customers.

We are now familiar with the administration interface, we created some products,  tax rates and a lot 
of  theoretical stuff.

In this chapter we want to have a look at the design of  our online store!

JOOMLA TEMPLATES
Joomla as a content management system uses  so called templates  for the design of your website. A 

template is  a layer on top of your data that defines e.g. the size and colour of a headline, the layout of an 
image,  the font of a text,  and all the little bits and pieces of your website that are displayed in your 
browser. A template is  the implementation of a style guide for your website. The same data can be 
displayed in a totally different way by using different templates.
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Joomla comes with a few preinstalled templates. These templates can be found in Extensions → 
Templates → Template Manager. The creation of a template is  a lot of work and often people only want 
to change some colours, logo, font and a few other pieces. To make this possible the Joomla team 
introduced template styles  in Joomla 1.6. A template style is  just a set of different parameters (colors) for 
the same template. One template can have unlimited styles  and each style can be tied to a menu link in 
Joomla.

You have a few possibilities to work with templates. You can

• use a core template style out of  the box and create your own styles based on a core template (easy)

• install a third party template (easy)

• tweak a core template by using overrides and layout alternatives (medium)

• create your own template from scratch (hard)

To be able to create a template from scratch,  you will not only need to have good design skills but 
also an understanding of  HTML, CSS, JavaScript and the Joomla specific enhancements.

TEMPLATES AND THE VIRTUEMART EXTENSION
VirtueMart is an extension of Joomla and it fits  into the Joomla template system. Every template that 

works well for Joomla will work for the VirtueMart component too ... but ...
An ecommerce website is a bit different compared to "just" a content management system. The most 
important aim is that customers are buying your goods. There are several reasons for them to buy goods 
online and often they compare the same products at different online shops. If the quality of your 
products  is  good, the prices are acceptable and on top your online shop looks pretty, is easy to 
understand and the check out process is  simple and reliable,  people will start buying! The user interface 
makes the difference. There are nearly "religious" debates about the "best" checkout process,  the "best" 
product details page,  the most "responsive" shopping cart and so on. I don't want to argue for this  or that 
solution. Everything will work when it's made with your heart and has a relationship to your products :)

Professional VirtueMart templates
The by far the fastest and easiest solution is  to buy a ready made professional template for your 

VirtueMart store.

To get an impression how this works  have a look at the Free Virtuemart template with quickstart 
demo from Yagendoo (Template demo, Template download, PDF documentation) (Figure 1).
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Figure 1: Free VirtueMart template Vision

You'll find more examples of professional templates  in the VirtueMart extension store, in several 
template clubs,  e.g. in an article in the January 2013 issue of the Joomla magazine - Top 10 Fashion 
VirtueMart Templates, and it is of  course a good idea to google for VirtueMart2 templates.

VirtueMart views template overrides
If you already have a template that fits your needs it's also possible to replace only the VirtueMart 

specific views  by using Joomlas  template override system. You can do this on your own or you can buy 
them (e.g. Yagendoo themes)

DO IT YOURSELF :)
I already warned you because of the work and the danger of becoming a design addict but I want to 

describe how easy it is to override a VirtueMart view with your own markup.

Where are the VirtueMart views located?

VirtueMart2 stores all the frontend views  generated by the component in [JOOMLAROOT]/
components/com_virtuemart/views/ (Figure 2). The module views are located in each virtuemart module 
folder.
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Figure 2: VirtueMart 2 views folder

Every output that is generated by VirtueMart 2 has its own view and its own variables.

Where do I have to put them in my template?
If you want to customize a view it's very important NOT to edit the original file. Otherwise your 

changings are gone after the next VirtueMart online update!

Copy the files you want to change in your template html folder. If your template has no html folder, 
create one!

Let's change the display around the add to cart button.

• copy the file
[joomlaroot]/components/com_virtuemart/views/productdetails/tmpl/default_addtocart.php
to
[joomlaroot]/templates/[yourtemplate]/html/com_virtuemart/productdetaisldefault_addtocart.php
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• edit [joomlaroot]/templates/[yourtemplate]/html/com_virtuemart/productdetaisldefault_addtocart.php in a 
text editor and add your code

The result
After saving the product details page looks different. I added the text "My individual view" (Figure 3).

Figure 3: Product details override

I want more!
If you want to change the CSS styles,  just override the existing CSS classes,  stored in the folder 

[joomlaroot]/components/com_virtuemart/assets/css/ with the help of Firebug and store the CSS commands in 
the appropriate CSS file of  your template.

If you want to add fancy effects, tabs,  sliders or similar stuff,  VirtueMart is already using the jQuery 
library. It's also stored in the assets folder and you can use it in every view.

CONCLUSION
Changing the design of your VirtueMart2 website is not complicated. It's just a lot of work and you 

need to be a kind of  an artist to get a good result.

Have fun playing around with VirtueMart views and overrides.
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8. Reviews & Ratings

http://www.flickr.com/photos/9555503@N07/5096020716/

Visitors expect that your online shop works  technically as  good as the Amazon website. Even when 
they know that you are a small company.

A good way to make your shop unique is the possibility to rate and review products. Product reviews 
are great for business, even the ones that aren’t positive.

Customers  want to make sure they are getting the best deal for their money. With reviews to each 
product they can read about why they should or should not purchase it. By clicking a link they are 
spending money on that same site.

This  is  also a way to create a network of loyal regular customers as  well as generate new ones. 
Product reviews are beneficial for businesses because they give consumers a reason to buy one product 
over another especially if the customer is trying to decide between options  on two different sites. If your 
site has more information including reviews about the product, the customer is  more likely to shop with 
your site than with a site with little to no information about the product.

CONFIGURATION
In VirtueMart 2 a five star rating field is combined with a review. To offer it to your visitors, you have 

to configure

• who can see and who can write reviews
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• whether reviews are automatically published or not

• the length of  the comment text

The default setting are a text length between 100 and 2,000 characters, everybody can see reviews 
and ratings, registered users can write them and they will be published automatically (Figure 1). It is 
possible to restrict the ability to review to customers who bought the product!

Figure 1: Configuration of  ratings and reviews

DISPLAY
The ratings will be displayed on the product detail page. Depending on the template they appear in 

tabs or under the product description (Figure 2).
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Figure 2: Reviews and rating in product details (bax-shop.nl)
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9. Multilingual Stores

http://www.flickr.com/photos/lrosa/2158835772/

In this  chapter we want to enhance a VirtueMart 2 shop to be a multilingual store. The simple aim is 
to have your products  available in different languages. When visitors  access  the English version of a 
product they should be able to switch to any available language versions of that product by clicking a flag 
or an option menu.

The good news is that it is  generally possible, not complicated to configure and it's  not necessary to 
buy additional extensions. It is possible to translate all your products, your categories,  your 
manufacturers  and to setup pricing and tax rules, payment and shipping methods depending on the 
language/country the customer comes from.

Before you start you have to think about which languages you want to use.

Joomla itself is available in more than 50 languages and VirtueMart 2 is using the Joomla multi 
language system. Most of the languages  that are available for Joomla are already installed in your 
VirtueMart 2 package. VirtueMart is  translated by the Open Translators group and this  is the place for 
translations at the VirtueMart website.

MULTILINGUAL JOOMLA
To get a multi language store you first have to configure Joomla 2.5 as a multilingual website.

I have written an entire chapter about that topic in the Joomla 2.5 Beginner's Guide (Multi-
Language Websites). There is also a screencast available (https://vimeo.com/28593435).
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MULTILINGUAL VIRTUEMART
Please make sure that your Joomla works  correctly in the languages you want to offer to your 

customers. 

Have a look in the folders [root]/language and [root]/administrator/languages and check whether you find 
VirtueMart files like en-GB.com_virtuemart.ini in your desired languages.

Go to Extensions → VirtueMart → Configuration → Shop  and add the languages you want to offer in your 
multilingual store (Figure 1)

Figure 1: Multilingual store

You are now able to translate your shop,  e.g. the categories. You can manage all the translations  in 
one edit form by switching the language option field on top (Figure 2).
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Figure 2: Category Translation

After the categories you can translate your products  in the same way. Just switch the language flags 
and enter the translations into the fields that are marked with a flag (Figure 3).

Figure 3: Product translation

This  is  all you have to do in VirtueMart to run a multi language store. It is possible too to translate 
vendors, payment methods, shipment methods, manufacturers and manufacturer categories.

PRODUCT DISPLAY

E-Commerce with VirtueMart 2

Sunday, 28 July 2013 Page 67



To display the different language versions of your VirtueMart 2 products on your Joomla website you 
usually use language specific menus and/or menu items. If you use the default Joomla settings you'll run 
in "problem".

Whenever you switch the site language by clicking the flag, when you are at a product page, e.g. a 
page like /en/jam/apricot-jam,  Joomla throws you to /fr or /de,  instead of giving you the page /fr/confiture/
confiture-d-abricot (the product's  page in French). To solve this problem you have to activate the menu 
association feature in the language filter plugin (Figure 4).

Figure 4: Plugin - Menu Associations

Now you can create menu items for your categories and also for your products. In the options of the 
menu item edit form you can associate the translated menu items with the original menu item. (Figure 5 
and 6).
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Figure 5: Menu item associations

Figure 6: Edit menu item associations

If you have too many products  to create menu item it is  enough to create them for your categories. 
The Joomla menu router has  a useful in build fallback system. If you are at the French product details 
page for "Confiture d'abricot"   and you switch to another language the menu router looks for an 
associated menu item. If it does  not exist it searches for the associated category. If it finds the category it 
switches to e.g. the English "Jam" category.
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At first sight this  behaviour sounds a bit strange but it is  also useful in case you have not translated 
any product.

All in all I believe it is a bit tricky to figure out the details and the relations  between VirtueMart 2 and 
Joomla. But when you finally managed to do so you get the great result having a multi language 
VirtueMart 2 shop with the core language feature of  Joomla :)

You might also want to have a look at VirtueMart documentation concerning the multi language 
setup.
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10. Shopper Groups

http://www.flickr.com/photos/thatrileygirl/12659907

People who are visiting your online shop are either visitors or registered users. Depending on your 
Joomla configuration they could create a user account without buying anything.

Usually, after they bought the first product, they are a registered user on your website.

In VirtueMart you can create shopper groups and assign them to registered users.

Within shopper groups you have the possibility to offer different products or prices to different users.

PREPARATIONS
To use this feature we need to create a shopping group and assign it to an user account.
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Create a shopper group under Components → VirtueMart → Orders & Shoppers → Shopper Groups → New. 
I create the Gold Member group (Figure 1).

Figure 1: Gold Member shopper group

Now we have to assign the shopper group to a user account. This can be achieved in Components → 
VirtueMart → Orders & Shoppers → Shopper → Edit (Figure 2).
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Figure 2: Assign shopper group to user account

Now, Toni is a gold member on our platform!

A PRODUCT ONLY FOR GOLD MEMBERS
To offer a special product only for gold members  like Toni you have to create the product and select 

the Shopper Group Gold Member in the Product Information tab (Figure 3)

Figure 3: Restrict a product to a shopper group

A DISCOUNT FOR EACH PRODUCT FOR GOLD MEMBERS
To offer a discount for each product to gold members  only, you have to create a rule in Components → 

VirtueMart → Products → Taxes & Calculation Rules (Figure 4).
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Figure 4: A discount rule for the Gold Member shopper group

A SPECIAL PRICE FOR ONE PRODUCT FOR GOLD MEMBERS
If you want to make a special price for one product for gold members,  you need to edit the product 

and add an additional price for the Shopper Group Gold Member in the Product pricing tab (Figure 5)
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Figure 5: A special product price for a shopper group

When you think about a marketing concept for your online store,  shopper groups can become a very 
interesting feature if  you combine it with newsletters, community events and other actions.
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After ten VirtueMart chapters I think you've got an idea of this  extension and you are equipped with 
enough knowledge to start your own online shop.
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More books from cocoate

Joomla! 2.5 Beginner’s Guide

Joomla! Development for Beginner’s

Going Mobile with Joomla!

http://cocoate.com/publications 
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cocoate.com is  the publisher of this  book and an independent management consultancy,  based in 
France and working internationally.

Specialized in three areas – Consulting,  Coaching and Teaching – cocoate.com develops  web based 
strategies for process  and project management and public relations;  provides  customized trainings  for 
open source content management systems Drupal,  Joomla and WordPress,  in the area of management 
and leadership skills and develops educational projects with the focus on non-formal learning.

The European educational projects  focus on the promotion of lifelong learning with the goal of 
social integration. Particular emphasis is  placed on learning methods in order to learn how to learn, the 
conception and realization of  cross-generational learning strategies and local community development.

http://cocoate.com 
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Spend your holidays in Southern France

We were captive to the charme of this  old French village from the beginning and that's  why we live 
and work in Fitou. We restored an old village house into holiday apartments  because we like to host 
guests and share with them our love for this region. 

Fitou is situated in the South of France, between Perpignan and Narbonne and is a typical French 
wine village having guarded the distinctive architectural village houses. The region around Fitou is 
known for its  wine and is as  diverse as it can be,  situated not too far from the Pyrenees  (one hour drive) 
and Spain. The Mediterranean climate allows  you to enjoy the freshness  of the Mediterranean sea at 
one of the beautiful beaches  enclosing the Étang from March until October,  as Languedoc-Roussillon is 
the sunniest area in France. The country of Cathar offers  not only old castles and abbeys but also the 
historical Canal du Midi.

Our apartments can be rented during the whole year. The apartments  are part of an old traditional 
stone house in the heart of Fitou. They have been carefully restored and modernized, respecting 
architectural aspects and conforming to the neighboring houses. Feel free to discover our apartments  and 
the region surrounding them!

http://fimidi.com 
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